Publication Date:
Last Update:
Current Version: V1.2
CVSS v3.1 Base Score: 6.5
Affected Product and Versions Remediation

All versions < V14 SP1 Update 14
Update to V14 SP1 Update 14 or later version

All versions

All versions < V16 Update 6
Update to V16 Update 6 or later version

All versions < V17 SP1

All versions

All versions < V3.1.1
  • Do not use OPC client feature to connect via untrusted networks or to untrusted OPC-UA communication partners
  • Use VPN for protecting network communication between cells

As a general security measure, Siemens strongly recommends to protect network access to devices with appropriate mechanisms. In order to operate the devices in a protected IT environment, Siemens recommends to configure the environment according to Siemens' operational guidelines for Industrial Security (Download: https://www.siemens.com/cert/operational-guidelines-industrial-security), and to follow the recommendations in the product manuals.

Additional information on Industrial Security by Siemens can be found at: https://www.siemens.com/industrialsecurity

The vulnerability classification has been performed by using the CVSS scoring system in version 3.1 (CVSS v3.1) (https://www.first.org/cvss/). The CVSS environmental score is specific to the customer’s environment and will impact the overall CVSS score. The environmental score should therefore be individually defined by the customer to accomplish final scoring.

An additional classification has been performed using the CWE classification, a community-developed list of common software security weaknesses. This serves as a common language and as a baseline for weakness identification, mitigation, and prevention efforts. A detailed list of CWE classes can be found at: https://cwe.mitre.org/.

CVSS v3.1 Base Score 6.5
CVSS Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H/E:P/RL:O/RC:C
CWE CWE-476: NULL Pointer Dereference

https://www.siemens.com/cert/advisories

V1.0 (2022-05-10): Publication Date
V1.1 (2022-07-12): Added fix for SIMATIC NET PC Software V16
V1.2 (2022-08-09): Added fix for TeleControl Server Basic