Publication Date:
Last Update:
Current Version: V1.5
CVSS v3.1 Base Score: 6.7
Affected Product and Versions Remediation

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions

All versions
  • Configure the SSH clients to make use of the following strong key exchange ciphers, supported by the ROS SSH server: ecdh-sha2-nistp256, ecdh-sha2-nistp384, or ecdh-sha2-nistp521
  • Add only trusted SSH client public keys to ROS and allow access to those clients only

Please follow the General Security Recommendations.

As a general security measure, Siemens strongly recommends to protect network access to devices with appropriate mechanisms. In order to operate the devices in a protected IT environment, Siemens recommends to configure the environment according to Siemens' operational guidelines for Industrial Security (Download: https://www.siemens.com/cert/operational-guidelines-industrial-security), and to follow the recommendations in the product manuals.

Additional information on Industrial Security by Siemens can be found at: https://www.siemens.com/industrialsecurity

The vulnerability classification has been performed by using the CVSS scoring system in version 3.1 (CVSS v3.1) (https://www.first.org/cvss/). The CVSS environmental score is specific to the customer’s environment and will impact the overall CVSS score. The environmental score should therefore be individually defined by the customer to accomplish final scoring.

An additional classification has been performed using the CWE classification, a community-developed list of common software security weaknesses. This serves as a common language and as a baseline for weakness identification, mitigation, and prevention efforts. A detailed list of CWE classes can be found at: https://cwe.mitre.org/.

CVSS v3.1 Base Score 6.7
CVSS Vector CVSS:3.1/AV:A/AC:H/PR:N/UI:R/S:U/C:L/I:H/A:H/E:P/RL:U/RC:C
CWE CWE-326: Inadequate Encryption Strength

  • Michael Messner from Siemens Energy for reporting the vulnerability

https://www.siemens.com/cert/advisories

V1.0 (2022-03-08): Publication Date
V1.1 (2022-03-11): Corrected the list of affected products and fix releases
V1.2 (2022-04-12): Added acknowledgements
V1.3 (2022-06-14): Corrected title, vulnerability description, CVSS vector and CWE ID; clarified that a fix release is currently not available for affected devices
V1.4 (2022-08-09): Reflected a more accurate fix status in advisory
V1.5 (2022-11-08): Reflect information about an upcoming fix. Highlight version lines of the affected devices